@tsteur opened this Issue on July 23rd 2015 Owner

In Dimensions we have some "hooks" / methods that are called during tracking: https://github.com/piwik/piwik/blob/2.14.1-rc1/core/Plugin/Dimension/VisitDimension.php#L216-L252

Same applies to ActionDimension and ConversionDimension eg

    public function onExistingVisit(Request $request, Visitor $visitor, $action)
        return false;

Problem is that we will never be able to change this signature as it might break plugins. Instead we should pass only one object where one can call $i->getRequest(), $i->getVisitor(), ... It is not as nicely readable etc but it will allow us to change code in the future and provide more parameters.

We potentially have similar issues with other classes too, eg Reports::configureWidgets(). Those would be ideally changed too. We should do this for 3.0.0 as it will break the API

@mattab commented on August 13th 2015 Owner

Since we do a LTS release #8546 and we will change our release cycle #8547 - we do not need this anymore

This Issue was closed on August 13th 2015
Powered by GitHub Issue Mirror