@anonymous-matomo-user opened this Issue on September 18th 2012

Steps to reproduce:

  • Dashboard: Set date range from 2012-09-04 to 2012-09-05
  • Click on "All Websites" -> nothing happens
  • Click on "Widgets"

The date '2012-09-04%2C2012-09-05' is not a correct date range. It should have the following format: 'lastN', 'previousN', 'YYYY-MM-DD,YYYY-MM-DD'.

If you first click on "Widgets" nothing happens and then on "All Websites", the same error message plus a backtrace is shown:

The date '2012-09-04%2C2012-09-05' is not a correct date range. It should have the following format: 'lastN', 'previousN', 'YYYY-MM-DD,YYYY-MM-DD'.

Go to Piwik
Login
Backtrace:
#0 /var/www/vhosts/piwik.example.com/httpdocs/core/Period.php(105): Piwik_Period_Range->generate()
#1 /var/www/vhosts/piwik.example.com/httpdocs/core/Period/Range.php(71): Piwik_Period->getDateStart()
#2 /var/www/vhosts/piwik.example.com/httpdocs/core/Period/Range.php(86): Piwik_Period_Range->getDateStart()
#3 /var/www/vhosts/piwik.example.com/httpdocs/core/Archive/Single.php(182): Piwik_Period_Range->getPrettyString()
#4 /var/www/vhosts/piwik.example.com/httpdocs/core/Archive/Array/IndexedBySite.php(192): Piwik_Archive_Single->prepareArchive()
#5 /var/www/vhosts/piwik.example.com/httpdocs/core/Archive/Array/IndexedBySite.php(131): Piwik_Archive_Array_IndexedBySite->getArchiveIdsAfterLaunching(Array)
#6 /var/www/vhosts/piwik.example.com/httpdocs/core/Archive/Array/IndexedBySite.php(108): Piwik_Archive_Array_IndexedBySite->loadValuesFromDB(Array)
#7 /var/www/vhosts/piwik.example.com/httpdocs/core/Archive/Array/IndexedBySite.php(73): Piwik_Archive_Array_IndexedBySite->getValues(Array)
#8 /var/www/vhosts/piwik.example.com/httpdocs/plugins/MultiSites/API.php(192): Piwik_Archive_Array_IndexedBySite->getDataTableFromNumeric(Array)
#9 /var/www/vhosts/piwik.example.com/httpdocs/plugins/MultiSites/API.php(112): Piwik_MultiSites_API->buildDataTable('all', 'range', '2012-09-04%2C20...', false, false, false)
#10 /var/www/vhosts/piwik.example.com/httpdocs/plugins/MultiSites/Controller.php(65): Piwik_MultiSites_API->getAll('range', '2012-09-04%2C20...', false)
#11 /var/www/vhosts/piwik.example.com/httpdocs/plugins/MultiSites/Controller.php(37): Piwik_MultiSites_Controller->getSitesInfo(Object(Piwik_View))
#12 function: Piwik_MultiSites_Controller->index()
#13 /var/www/vhosts/piwik.example.com/httpdocs/core/FrontController.php(138): call_user_func_array(Array, Array)
#14 /var/www/vhosts/piwik.example.com/httpdocs/index.php(53): Piwik_FrontController->dispatch()
#15 {main}

@mattab commented on September 19th 2012 Member

fixed in [-- revert partial of 6114 Refs #534 - Fixes #3387 Double encoding issue. Thanks larsen for report!

This Issue was closed on September 19th 2012
Powered by GitHub Issue Mirror