I added hooks and comments to them directly in Auth class. Also I changed names of these events, to be consistent with the naming convention used in this class.
As a minor change I've renamed function processSuccessfullSession. (phpstorm spellchecker has problem with this)
If you have any questions or other vision how to write this then feel free to contact me!
Looks good, I like how you named the 'Login.authenticate' and 'Login.authenticate.successful'
I'll merge it now, but for completion, maybe you'd like to add the 'Login.authenticate.failure' event?
No problem. I'll add failure Hood.
I talked too early, let's add not add un-needed events, this was bad idea ;) it's good as it is