@anonymous-matomo-user opened this Issue on March 23rd 2012

Hello,
Not that this is such an issue, but strictly speaking, "self" should be used instead of "Piwik_Common" within the Piwik_Common class :

Piwik_Common::getCacheGeneral()
Piwik_Common::initCorePiwikInTrackerMode()
Piwik_Common::sanitizeInputValue()
Piwik_Common::HTML_ENCODING_QUOTE_STYLE
@anonymous-matomo-user commented on March 23rd 2012

Is there any reason to use Piwik_Common instead of self there ?

Please enlighten me.

@robocoder commented on March 23rd 2012 Contributor

Usually it's just a matter of personal coding style.

But if you refer to #2954, there are also backward compatibility issues.

This Issue was closed on March 23rd 2012
Powered by GitHub Issue Mirror