Login flow processor using to hook up into init session process as next layer of authenticate.
I tried to refactor Auth class following your suggestion. But i don't really understand the naming of events you chose, in the login flow object. IMHO it would be better to put hooks in the Auth object to keep things clear, and always name hooks according to method they are triggered from.
Also let's add a comment to the hook so it shows up in the documentation here: http://developer.piwik.org/api-reference/events (this page is automatically generated from the source code comments).
Let me know what you think...