@robocoder opened this Issue on February 27th 2012 Contributor

Patch from V.Krishn to update Smarty from 2.6.26 to 3.1.8 (originally posted to the piwik-hackers mailing list).

@robocoder commented on February 27th 2012 Contributor
@robocoder commented on February 27th 2012 Contributor

Note: Smarty has a minimum php 5.2 requirement.

Note: we have a custom version of Smarty 2.6.26 because local bug fixes were reported but never merged upstream.

@mattab commented on February 27th 2012 Member

If there is no security fix, we might not want to upgrade. Because requiring 5.2 would be potentially dangerous for existing users?

@robocoder commented on February 28th 2012 Contributor

We can test for (and workaround) 5.1.x regressions. I'm more interested in seeing if our local mods have been addressed in 3.x, and performance improvement.

@mattab commented on December 14th 2012 Member

please reopen if patch is valid and you think should be applied (please explain why)

This Issue was closed on December 14th 2012
Powered by GitHub Issue Mirror