@anonymous-matomo-user opened this Issue on February 22nd 2012

The "Plugins" table under "Visitors" - "Settings" shows following strange behavior:

  1. The visits percentage with Flash plugin is shown above 100% (102.1%)
  2. The shown percentage seems to be inconsistent with the absolute number of visits. E.g.: if 60 visits corresponds to 100% ("Cookies"), how can 39 visits correspond to 81.3% ("Pdf"), and so on.

See attached screenshot for information. This seems to be related to #1496.

@anonymous-matomo-user commented on February 22nd 2012
@anonymous-matomo-user commented on February 22nd 2012

It doesn't get asked in the bug submission form: Piwik version 1.7 is meant. But I'm not sure how long this has been around, maybe I just never noticed.

@mattab commented on February 22nd 2012 Member

Thanks for the report, it seems there is a problem indeed.

@robocoder commented on March 16th 2012 Contributor

Cookie and Java - includes IE users, so:

  • Cookie 60/60 = 100%
  • Java 42/60 =70%

The other plugins exclude IE users. It looks like one non-IE user changed their user agent to masquerade as IE, this means the Flash detection is over-reported (49 instead of 48).

  • Flash 49/48 = 102.1%
  • Pdf 39/48 = 81.83%
  • etc...

This is confusing to users given that the widget currently has the footnote:
Note: Plugins detection doesn't work in Internet Explorer. This report is only based on non-IE browsers
but is obviously not accurate given the above explanation.

@robocoder commented on March 16th 2012 Contributor

(In [6056]) refs #2962 - no hope of IE ever supporting plugin detection; so disable it from the start

@robocoder commented on March 16th 2012 Contributor

(In [6057]) refs #2962 - don't correct for IE

@robocoder commented on March 16th 2012 Contributor

Now... what to do with historical data?

@mattab commented on March 19th 2012 Member

Oh good guess about browser faking IE user agents. Your solution looks good.

About historical data: maybe we can cap the percentage at 100% max if it could be higher for previous days?

@robocoder commented on May 12th 2012 Contributor

(In [6258]) fixes #2962 - add RangeCheck filter

@robocoder commented on May 12th 2012 Contributor

(In [6262]) refs #2962

@mattab commented on May 31st 2012 Member

I noticed that the value for 100% is displayed as "100" but other values are correctly displayed with % sign "88%"

This Issue was closed on May 31st 2012
Powered by GitHub Issue Mirror