@robocoder opened this Issue on December 23rd 2011 Contributor
PHP Strict Standards:  Declaration of __dummyConverter::setTargetDir() should be compatible with Converter::setTargetDir($dir) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/Converter.inc on line 5459
PHP Strict Standards:  Declaration of __dummyConverter::setTemplateDir() should be compatible with Converter::setTemplateDir($dir) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/Converter.inc on line 5459
PHP Strict Standards:  Declaration of HTMLframesConverter::convertConst() should be compatible with Converter::convertConst(&$element, $additions = Array) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/Converters/HTML/frames/HTMLframesConverter.inc on line 1889
PHP Strict Standards:  Declaration of HTMLframesConverter::convertDefine() should be compatible with Converter::convertDefine(&$element, $addition = Array) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/Converters/HTML/frames/HTMLframesConverter.inc on line 1889
PHP Strict Standards:  Declaration of HTMLframesConverter::convertFunction() should be compatible with Converter::convertFunction(&$element, $addition = Array) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/Converters/HTML/frames/HTMLframesConverter.inc on line 1889
PHP Strict Standards:  Declaration of HTMLframesConverter::convertGlobal() should be compatible with Converter::convertGlobal(&$element, $addition = Array) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/Converters/HTML/frames/HTMLframesConverter.inc on line 1889
PHP Strict Standards:  Declaration of HTMLframesConverter::convertInclude() should be compatible with Converter::convertInclude(&$element, $addition = Array) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/Converters/HTML/frames/HTMLframesConverter.inc on line 1889
PHP Strict Standards:  Declaration of HTMLframesConverter::convertMethod() should be compatible with Converter::convertMethod(&$element, $additions = Array) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/Converters/HTML/frames/HTMLframesConverter.inc on line 1889
PHP Strict Standards:  Declaration of HTMLframesConverter::convertTutorial() should be compatible with & Converter::convertTutorial(&$element) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/Converters/HTML/frames/HTMLframesConverter.inc on line 1889
PHP Strict Standards:  Declaration of HTMLframesConverter::convertVar() should be compatible with Converter::convertVar(&$element, $additions = Array) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/Converters/HTML/frames/HTMLframesConverter.inc on line 1889
PHP Strict Standards:  Declaration of HTMLframesConverter::getId() should be compatible with Converter::getId(&$link) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/Converters/HTML/frames/HTMLframesConverter.inc on line 1889
PHP Strict Standards:  Declaration of HTMLframesConverter::getPageLink() should be compatible with Converter::getPageLink($expr, $package, $path = false, $text = false, $packages = false) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/Converters/HTML/frames/HTMLframesConverter.inc on line 1889
PHP Strict Standards:  Declaration of HTMLframesConverter::Output() should be compatible with Converter::Output($title) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/Converters/HTML/frames/HTMLframesConverter.inc on line 1889
PHP Strict Standards:  Declaration of methodLink::addLink() should be compatible with abstractLink::addLink($path, $fileAlias, $name, $package, $subpackage, $category = false) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/LinkClasses.inc on line 267
PHP Strict Standards:  Declaration of parserB::Convert() should be compatible with parserStringWithInlineTags::Convert(&$converter, $postprocess = true, $trim = true) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/DescHTML.inc on line 176
PHP Strict Standards:  Declaration of parserBr::Convert() should be compatible with parserStringWithInlineTags::Convert(&$converter, $postprocess = true, $trim = true) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/DescHTML.inc on line 341
PHP Strict Standards:  Declaration of parserCData::Convert() should be compatible with parserStringWithInlineTags::Convert(&$converter, $postprocess = true, $trim = true) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/PackagePageElements.inc on line 99
PHP Strict Standards:  Declaration of parserCode::Convert() should be compatible with parserStringWithInlineTags::Convert(&$converter, $postprocess = true, $trim = true) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/DescHTML.inc on line 109
PHP Strict Standards:  Declaration of parserDescParser::parse() should be compatible with Parser::parse(&$parse_data, $path, $base = 0, $packages = false) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/ParserDescCleanup.inc on line 1486
PHP Strict Standards:  Declaration of parserDescParser::setupStates() should be compatible with Parser::setupStates() in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/ParserDescCleanup.inc on line 1486
PHP Strict Standards:  Declaration of parserDescVar::Convert() should be compatible with parserStringWithInlineTags::Convert(&$converter, $postprocess = true, $trim = true) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/DescHTML.inc on line 242
PHP Strict Standards:  Declaration of parserI::Convert() should be compatible with parserStringWithInlineTags::Convert(&$converter, $postprocess = true, $trim = true) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/DescHTML.inc on line 209
PHP Strict Standards:  Declaration of parserKbd::Convert() should be compatible with parserStringWithInlineTags::Convert(&$converter, $postprocess = true, $trim = true) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/DescHTML.inc on line 308
PHP Strict Standards:  Declaration of parserList::Convert() should be compatible with parserStringWithInlineTags::Convert(&$converter, $postprocess = true, $trim = true) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/DescHTML.inc on line 421
PHP Strict Standards:  Declaration of parserPackagePage::Convert() should be compatible with parserStringWithInlineTags::Convert(&$converter, $postprocess = true, $trim = true) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/ParserElements.inc on line 2052
PHP Strict Standards:  Declaration of parserPre::Convert() should be compatible with parserStringWithInlineTags::Convert(&$converter, $postprocess = true, $trim = true) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/DescHTML.inc on line 143
PHP Strict Standards:  Declaration of parserSamp::Convert() should be compatible with parserStringWithInlineTags::Convert(&$converter, $postprocess = true, $trim = true) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/DescHTML.inc on line 275
PHP Strict Standards:  Declaration of parserTag::Convert() should be compatible with parserStringWithInlineTags::Convert(&$converter, $postprocess = true, $trim = true) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/DocBlockTags.inc on line 185
PHP Strict Standards:  Declaration of parserTag::getString() should be compatible with parserStringWithInlineTags::getString($trim = true) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/DocBlockTags.inc on line 185
PHP Strict Standards:  Declaration of parserXMLDocBookTag::Convert() should be compatible with parserStringWithInlineTags::Convert(&$converter, $postprocess = true, $trim = true) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/PackagePageElements.inc on line 458
PHP Strict Standards:  Declaration of phpDocumentor_HighlightParser::commonDocBlock() should be compatible with phpDocumentorTParser::commonDocBlock($word, $pevent, $deschandler) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/HighlightParser.inc on line 2602
PHP Strict Standards:  Declaration of phpDocumentor_HighlightParser::parse() should be compatible with Parser::parse(&$parse_data, $path, $base = 0, $packages = false) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/HighlightParser.inc on line 2602
PHP Strict Standards:  Declaration of phpDocumentor_HighlightParser::setupStates() should be compatible with Parser::setupStates() in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/HighlightParser.inc on line 2602
PHP Strict Standards:  Declaration of phpDocumentor_HighlightWordParser::backupPos() should be compatible with WordParser::backupPos($word) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/HighlightParser.inc on line 208
PHP Strict Standards:  Declaration of phpDocumentor_HighlightWordParser::setup() should be compatible with WordParser::setup(&$input) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/HighlightParser.inc on line 208
PHP Strict Standards:  Declaration of phpDocumentorTParser::categoryTagHandler() should be compatible with Parser::categoryTagHandler($word) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/phpDocumentorTParser.inc on line 2945
PHP Strict Standards:  Declaration of phpDocumentorTParser::configWordParser() should be compatible with Parser::configWordParser($e) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/phpDocumentorTParser.inc on line 2945
PHP Strict Standards:  Declaration of phpDocumentorTParser::defaultTagHandler() should be compatible with Parser::defaultTagHandler($word) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/phpDocumentorTParser.inc on line 2945
PHP Strict Standards:  Declaration of phpDocumentorTParser::exampleTagHandler() should be compatible with Parser::exampleTagHandler($word) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/phpDocumentorTParser.inc on line 2945
PHP Strict Standards:  Declaration of phpDocumentorTParser::globalTagHandler() should be compatible with Parser::globalTagHandler($word) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/phpDocumentorTParser.inc on line 2945
PHP Strict Standards:  Declaration of phpDocumentorTParser::handleDesc() should be compatible with Parser::handleDesc($word, $pevent) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/phpDocumentorTParser.inc on line 2945
PHP Strict Standards:  Declaration of phpDocumentorTParser::handleTags() should be compatible with Parser::handleTags($word, $pevent) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/phpDocumentorTParser.inc on line 2945
PHP Strict Standards:  Declaration of phpDocumentorTParser::packageTagHandler() should be compatible with Parser::packageTagHandler($word) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/phpDocumentorTParser.inc on line 2945
PHP Strict Standards:  Declaration of phpDocumentorTParser::paramTagHandler() should be compatible with Parser::paramTagHandler($word) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/phpDocumentorTParser.inc on line 2945
PHP Strict Standards:  Declaration of phpDocumentorTParser::propertyTagHandler() should be compatible with Parser::propertyTagHandler($word) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/phpDocumentorTParser.inc on line 2945
PHP Strict Standards:  Declaration of phpDocumentorTParser::returnTagHandler() should be compatible with Parser::returnTagHandler($word) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/phpDocumentorTParser.inc on line 2945
PHP Strict Standards:  Declaration of phpDocumentorTParser::staticvarTagHandler() should be compatible with Parser::staticvarTagHandler($word) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/phpDocumentorTParser.inc on line 2945
PHP Strict Standards:  Declaration of phpDocumentorTParser::usesTagHandler() should be compatible with Parser::usesTagHandler($word) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/phpDocumentorTParser.inc on line 2945
PHP Strict Standards:  Declaration of phpDocumentorTParser::varTagHandler() should be compatible with Parser::varTagHandler($word) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/phpDocumentorTParser.inc on line 2945
PHP Strict Standards:  Declaration of phpDocumentor_TutorialHighlightParser::parse() should be compatible with Parser::parse(&$parse_data, $path, $base = 0, $packages = false) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/TutorialHighlightParser.inc on line 527
PHP Strict Standards:  Declaration of phpDocumentor_TutorialHighlightParser::setupStates() should be compatible with Parser::setupStates() in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/TutorialHighlightParser.inc on line 527
PHP Strict Standards:  Declaration of phpDocumentorTWordParser::backupPos() should be compatible with WordParser::backupPos($word) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/phpDocumentorTWordParser.inc on line 385
PHP Strict Standards:  Declaration of XMLPackagePageParser::parse() should be compatible with Parser::parse(&$parse_data, $path, $base = 0, $packages = false) in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/XMLpackagePageParser.inc on line 643
PHP Strict Standards:  Non-static method Io::isIncludeable() should not be called statically, assuming $this from incompatible context in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/IntermediateParser.inc on line 1740
PHP Strict Standards:  Non-static method phpDocumentor_setup::checkIgnoreTag() should not be called statically, assuming $this from incompatible context in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/ParserData.inc on line 820
PHP Strict Standards:  Non-static method phpDocumentor_setup::checkIgnoreTag() should not be called statically, assuming $this from incompatible context in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/ParserDocBlock.inc on line 613
PHP Strict Standards:  Non-static method phpDocumentor_setup::checkIgnoreTag() should not be called statically, assuming $this from incompatible context in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/ParserDocBlock.inc on line 955
PHP Strict Standards:  Non-static method phpDocumentor_setup::checkIgnoreTag() should not be called statically, assuming $this from incompatible context in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/ParserDocBlock.inc on line 966
PHP Strict Standards:  Only variables should be passed by reference in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/Setup.inc.php on line 752
PHP Strict Standards:  Only variables should be passed by reference in /usr/local/PhpDocumentor-1.4.3/phpDocumentor/Smarty-2.6.0/libs/Smarty_Compiler.class.php on line 712
@robocoder commented on December 26th 2011 Contributor

Updated the CI server to PhpDocumentor 1.4.4 (from 1.4.3). (DONE)

I took a look at the code, but because it supports php 4.2.0, it'll take a lot of refactoring to make it php 5 strict. (WONTFIX)

This Issue was closed on December 26th 2011
Powered by GitHub Issue Mirror