@anonymous-piwik-user opened this Issue on October 8th 2011

XXX.XXX.XXX.XXX - - +0200 "GET /dummypage.html HTTP/1.1" 200 2843 "http://www.example.org/" "Mozilla/5.0 (Linux; U; Android 2.2; de-de; HTC Desire 2.33.161.2 Build/FRF91) AppleWebKit/533.1 (KHTML, like Gecko) Version/4.0 Mobile Safari/533.1"

will be detected as "Android 4.0 with plugins flash enabled"

@robocoder commented on October 8th 2011 Contributor

If you're looking at the Browser report, it's reporting the browser version. Version/4 is explicitly set in the user agent so it is customary to use that value. Using the Android OS version is wrong imho. Maybe we should just report it as Safari or Mobile Safari?

@robocoder commented on October 8th 2011 Contributor

A patch for Chrome on Android reportedly landed this past week, so we'll report as Safari to avoid later confusion.

@robocoder commented on October 8th 2011 Contributor

(In [5272]) fixes #2694 - detect current Android browser as Safari (like iPad/iPhone/iPod); added a ficticious mobile Chrome user agent (commented out for now, but it works)

@robocoder commented on October 8th 2011 Contributor

(In [5273]) refs #2694 - remove remnants of "Android" browser (obsolete)

@robocoder commented on October 8th 2011 Contributor

FYI if/when mobile Chrome comes to Android, it'll be reported as Chrome

@anonymous-piwik-user commented on August 4th 2013

This bug is not fixed, the problem still persists in version 1.12.

@mattab commented on August 9th 2013 Member

What is the bug exactly? what user agent, what is behavior VS what do you expect? create a new ticket

This Issue was closed on August 9th 2013
Powered by GitHub Issue Mirror