@mattab opened this Issue on April 11th 2011 Member

as much as I hate IE we must fix this!

Calendar doesn't show the days, simply the first row of the calendar... if anyone is keen to debug this please do :)

@sgiehl commented on April 11th 2011 Member

Attachment:
ie7.png

@sgiehl commented on April 11th 2011 Member

(In [4401]) refs #2295 IE <9 can't handle new Date('yy-mm-dd') use datepickers
parsedate instead. layout is still broken in ie <9

@mattab commented on April 11th 2011 Member

Thanks Steve good stuff! It is working in IE8 now as well, why do you say it doesn't work in IE<9 ?

@sgiehl commented on April 11th 2011 Member

Couldn't test it in IE 8 right now. In IE 7 the layout is broken

@mattab commented on April 11th 2011 Member

selecting date ranges work in current month, but if I change months I get:


Message: 'G.j().images' is null or not an object
Line: 51
Char: 352
Code: 0
URI: http://localhost/trunk/index.php?module=Proxy&action=getPieHtc
@sgiehl commented on April 11th 2011 Member

That sounds like a problem with the pie. Will take a look at this later.

@mattab commented on April 11th 2011 Member

Also on the Widgets page I see a "Expected ; at the end of" with a garbage line (WHY does this debugger does NOT tell the right line, even with developer tools grrrr)

@mattab commented on April 11th 2011 Member

After updating to trunk and the new version of CSS PIE, the problem is still there so it is a different one..

The JS bug appears:

Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
Timestamp: Mon, 11 Apr 2011 21:41:37 UTC

Message: Expected ';'
Line: 78421269
Char: 22
Code: 0
URI: http://localhost/trunk/index.php?module=CoreHome&action=index&idSite=1&period=range&date=last30

The debugger won't give the backtrace or give the proper line number, I'm not sure how to go to debug this?

@mattab commented on April 11th 2011 Member

Note that now the date range works in IE8, but there is this JS error (not sure if it breaks anything?)

@sgiehl commented on April 11th 2011 Member

(In [4412]) refs #2295 fixes layout problem in IE7

@sgiehl commented on April 12th 2011 Member

(In [4414]) refs #2295 fixes manual input of a date in ie <9

@sgiehl commented on April 12th 2011 Member

matt, I can't reproduce your error in IE8 or IE7. Did that error occur with merged assets enabled or disabled?

@mattab commented on April 12th 2011 Member

I get the error on IE 8.0.6001 (I think latest version?) with both merged assets enabled or disabled, on the Dashboard page and on the Widgets page.

I dont get it on API/All Websites/Email reports pages so probably a problem in the menu or datatable code.

@sgiehl commented on April 12th 2011 Member

(In [4422]) refs #2295 no need to load ieonly.css in ie9, cause pie not needed here

@sgiehl commented on April 12th 2011 Member

Well, tried to reproduce it on another system now, but its working here aswell. No JS-Errors ouccred while switching dates.

While testing I sometimes had the issue that the pie seemed to break the complete layout in IE8. Do you have that problem, too?

I think we should consider removing the pie again in the future, as now IE9 supports rounded corners.

Btw is the latest tag already available on the demo? Maybe I could reproduce the error there.

@mattab commented on April 13th 2011 Member

Thanks Steve I pushed 1.3rc1 to the demo and it is working fine, excellent!

This Issue was closed on April 13th 2011
Powered by GitHub Issue Mirror