@stbaum opened this Issue on January 11th 2023

The AdvertisingConversionExport does not show up Ecommerce Goals!

Matomo Version 4.13.0
AdvertisingConversionExport 4.1.1

As shown in screenshots it should be possible to use existing ecommerce data as goals for advertising conversion exports, however this is not possible. If you need more informations, jus contact me.

image

@AltamashShaikh commented on January 12th 2023 Contributor

@stbaum Does running ./console cache:clear and trying again helps ?

@stbaum commented on January 12th 2023

@stbaum Does running ./console cache:clear and trying again helps ?

tried, but does not help.

@AltamashShaikh commented on January 12th 2023 Contributor

@stbaum You should be able to see "Ecommerce orders" as shown below
Screenshot from 2023-01-12 10-33-42

Do you have any error in the console ?

As per the code if its isEcommerceSite you should be able to see atleast "Ecommerce Orders" in the dropdwon

@stbaum commented on January 12th 2023

No I do not see it:

image

All I see is my manual setup goal

image

Site is ecommerce enabled, see 1st screenshot.

@stbaum commented on January 12th 2023

Do you have any error in the console ?

Which command to show error, currently everything seems fine:

root@ryz2 /var/www/matomo/tmp/logs # /var/www/matomo/console diagnostics:run
There are no problems with your Matomo setup. Give yourself a pat on the back.

@AltamashShaikh commented on January 12th 2023 Contributor

@stbaum Can you check if its showing up as "Ecommerce: yes" in the Measurables
Screenshot from 2023-01-12 13-40-48

Also check the idSite in the URL is correct, we cannot seem to find why the goal named "Ecommerce Orders" won't show up

@stbaum commented on January 12th 2023

All websites are E-COMMERCE YES
I do not see any problems with the IDs as well

image

@AltamashShaikh commented on January 13th 2023 Contributor

@stbaum On the below page
image

Can you open the network tab, refresh the page and filter for getSitesWithAtLeastViewAccess and check the response for you siteID, does it have ecommerce: "1"
Screenshot from 2023-01-13 08-49-23

@stbaum commented on January 13th 2023

If you contact me by mail. I could give you full access to the instance, maybe this would speed up the fix.
you may contact me by sb[at]kmp360.de

image

@AltamashShaikh commented on January 13th 2023 Contributor

@stbaum I couldn't do that sorry, can you please open a support ticket for this issue, since its a premium feature issue such issues should be raised via support and we can connect and ask for better info on this

@stbaum commented on January 13th 2023

Varun from the support team wrote to me, that I should continue here (some hours ago) ...

Powered by GitHub Issue Mirror