@Starker3 opened this Issue on May 29th 2022 Contributor

With some recent plugin updates there were higher minimum versions set for those plugins.
With users who have an install of Matomo that is not the latest version, the plugins page shows that plugin updates are available but show a big red warning that the plugin isn't compatible with their version of Matomo. Eg.
image

For Many users this can cause them to think that the version of the plugin they currently have installed is not compatible. We could perhaps show a different message to indicate that the version they are trying to update to is not compatible with their version of Matomo and perhaps change it to a warning (Eg. Orange/Yellow) instead of an error (Red). For example:
image

@peterhashair commented on May 29th 2022 Contributor

@Starker3 thanks for reporting this, our product team will process this ASAP

@AltamashShaikh commented on May 30th 2022 Contributor

@Starker3 The higher min version is due to recent migration to vue.js and it is expected

@Starker3 commented on May 30th 2022 Contributor

@AltamashShaikh Yes, the min version being higher isn't the problem here. The problem here is that the warning isn't very clear and can cause confusion.

Powered by GitHub Issue Mirror