@niklasternstedt opened this Issue on April 27th 2022

Expected Behavior

It should not appear a error message inside Matomo with the info:
"The plugin GoogleAnalyticsImporter could not be loaded as it has missing dependencies: GoogleAnalyticsImporter requires Matomo >=4.10.0-b1. Please contact your Matomo administrator."

Current Behavior

Same as above

Possible Solution

Update the plugin Google Analytics import so it is compatible with the latest version of Matomo

Context

The plugin do not work

Your Environment

  • Matomo Version: 4.9.1
  • PHP Version: 7.4.27
  • Browser: Brave
  • Operating System: iOS
@Findus23 commented on April 27th 2022 Member

Hi,

How did you install the plugin?

From the Marketplace or did you manually download and extract it?

@Findus23 commented on April 27th 2022 Member

Update the plugin Google Analytics import so it is compatible with the latest version of Matomo

The issue is more the other way around: The latest version of GA-import requires the next version of Matomo (which will be released in weeks). But this means it also should not be recommended to anyone to be installed.

@sgiehl commented on April 28th 2022 Member

I'll close this one. It should be automatically fixed with the upcoming release. It actually slipped through that the new version of the plugin will only be compatible with a not yet released version of Matomo. Normally this shouldn't happen and we will try to prevent that this happens again.

@niklasternstedt commented on May 2nd 2022

Thanks for the answers 👍

@MatomoForumNotifications commented on May 11th 2022

This issue has been mentioned on Matomo forums. There might be relevant details there:

https://forum.matomo.org/t/googleanalyticsimporter-required-executables-nohup/37982/4

@MatomoForumNotifications commented on May 18th 2022

This issue has been mentioned on Matomo forums. There might be relevant details there:

https://forum.matomo.org/t/incompability-problem-with-googleanalyticsimporter-on-matomo-4-6-2/45974/2

This Issue was closed on April 28th 2022
Powered by GitHub Issue Mirror