@tsteur opened this Issue on April 8th 2022 Member

This is with Matomo 4.8 on PHP8

I'm trying to edit a goal like this:

image

but no funnels configuration shows up and no update button.

seeing in console this error:

image

call stack:

imageimageimage

This is happening in our own Matomo.

To reproduce I followed these steps

  • opened "Manage Goals" /index.php?module=CoreHome&action=index&idSite=12&period=week&date=today#?idSite=12&period=day&date=2022-04-08&category=Goals_Goals&subcategory=Goals_ManageGoals
  • Then clicked on "Manage Goals" again

Then the JS error happens and you can't edit anything anymore.
This must be a regression.

@sgiehl commented on April 8th 2022 Member

Seems this was already fixed. I'm able to reproduce that locally with 4.8.0, but with 4.9.0-rc1 this doesn't happen anymore.

@tsteur commented on April 10th 2022 Member

👍 feel free to close in that case

@MatomoForumNotifications commented on April 14th 2022

This issue has been mentioned on Matomo forums. There might be relevant details there:

https://forum.matomo.org/t/plugin-goals-error-after-update-4-9-0/45519/3

@niklasternstedt commented on April 21st 2022

It is still a problem if a want to add a new goal when I don't have any goals. Then I get this error message:
Oops… there was a problem during the request. Maybe the server had a temporary issue, or maybe you requested a report with too much data. Please try again. If this error occurs repeatedly please contact your Matomo administrator for assistance. [See the steps to resolve this issue in the FAQ.](https://matomo.org/faq/troubleshooting/faq_19489/)

@koljam commented on April 27th 2022

It is still a problem if a want to add a new goal when I don't have any goals. Then I get this error message: Oops… there was a problem during the request. Maybe the server had a temporary issue, or maybe you requested a report with too much data. Please try again. If this error occurs repeatedly please contact your Matomo administrator for assistance. [See the steps to resolve this issue in the FAQ.](https://matomo.org/faq/troubleshooting/faq_19489/)

There seems to be a workaround until there is a new release: https://github.com/matomo-org/matomo/issues/19124#issuecomment-1104636551

@sgiehl commented on April 28th 2022 Member

@koljam a first release candidate for Matomo 4.10.0 will be released next week. That one should fix this issue.

This Issue was closed on April 11th 2022
Powered by GitHub Issue Mirror