@robocoder opened this Issue on December 11th 2010 Contributor

Microsoft's Web App Gallery team wants us to make changes for deployment via WebMatrix. We deferred this from around the time of 0.6.4 as we were pushing towards 1.0. I'm still in email discussion to refine the details, but it'll involve adding "install.sql" and changes to "parameters.xml" to:

  • prompt for db name, and root db user/password
  • use placeholders for those parameters

The Parallels team also asked that we takeover builds.

I was thinking:

  • we set up a repository for build scripts
  • the CI server could build packages (latest.zip without the WebAppGallery specific files, and vendor-specific packages)
@robocoder commented on December 13th 2010 Contributor

(In [3435]) refs #1885 - updated parameters.xml supplied by WebAppGal team

@robocoder commented on December 14th 2010 Contributor

(In [3438]) refs #1885 - add install.sql per Pete Harris @ Microsoft's recommendations

@robocoder commented on December 16th 2010 Contributor

(In [3449]) refs #1885 - create a package folder for build-specific scripts and files; move WAG and add latest build.script

@robocoder commented on December 16th 2010 Contributor

(In [3450]) refs #1885 - remove old folder

@robocoder commented on December 18th 2010 Contributor

(In [3455]) refs #1885 - update test build scripts

@robocoder commented on December 18th 2010 Contributor

(In [3456]) refs #1885 - update test build scripts -- this time, include install.sql

@robocoder commented on December 18th 2010 Contributor

(In [3458]) refs #1885 - update test build scripts again

@robocoder commented on December 19th 2010 Contributor

(In [3464]) fixes #1885; deferring Parallels support until their requirements have been reviewed

This Issue was closed on December 19th 2010
Powered by GitHub Issue Mirror