@Chardonneaur opened this Issue on April 26th 2021

When we click on the titles of each channel sources at the bottom of the overview graph, it works for the first two channels, then it goes to 0 for every period.

Expected Behavior

When we click on direct traffic, it should plot the direct traffic, when we click on campaigns it should plot the campaign traffic...

Current Behavior

It gets buggy after two clicks

Possible Solution

Force the update.

@flamisz commented on April 27th 2021 Contributor

Hi @Chardonneaur, sorry about this. It's indeed a bug, as we can easily reproduce it on the demo site here. After the 3rd click we get only flat graphs.

I set this issue as bug so we can hopefully get things sorted soon.

@mkindred commented on May 12th 2021

I think this is related to the issue I called attention to in the forums https://forum.matomo.org/t/acquisition-overview-multiple-bugs/41308 and possibly as far back as 2019 https://forum.matomo.org/t/3-13-bug-in-acquisition-overview/35248

But I noticed the bug when I opened the pulldown above the graph that allows you to select Records to Plot. Doing so eventually causes all the graph data to flatline to zero, and it also seems to result in URL-encoded characters in the 'records to plot' labels.

This is also reproducible in the demo site.

@mattab commented on September 28th 2021 Member

i could reproduce the issue, steps:

  • Go to demo
  • Under evolution graph click on the sparkline eg. 1,620 from search engines, 56% of visits -16.5%
  • the graph loads correctly
  • then click again
  • got: the graph is now empty
  • expected: the graph loads correctly

Screenshot from 2021-09-28 14-22-33

(fyi: In some other cases I get a different issue, but i couldn't exactly reproduce it, where the graph label appears double encoded, see screenshot below. this issue might be automatically fixed when we fix the above)

Screenshot from 2021-09-28 14-18-51

@sgiehl commented on September 29th 2021 Member

This could possibly be fixed with https://github.com/matomo-org/matomo/pull/18016

Powered by GitHub Issue Mirror