@danguyf opened this Issue on February 25th 2021

Summary

Many existing Matomo 3.x installs are using the CASLogin plugin, developed in response to this issue, to integrate SSO with Matomo.

With the move to Matomo 4.x, many of the methods and classes used by CASLogin have been removed. The developer has not responded to an issue opened Dec 2020.

Until there is an update or replacement for the CASLogin plugin, those users will not be able to upgrade.

Your Environment

  • Matomo Version: 3.x -> 4.x
  • PHP Version: 7.x
  • Server Operating System: RHEL7
@dlecan commented on March 4th 2021
@mbdeme commented on March 17th 2021

@dlecan can we use the plugin LoginOIDC to link CAS and motomo version 4?

@dlecan commented on March 17th 2021

can we use the plugin LoginOIDC to link CAS and motomo version 4?

Yes, you can, it's working perfectly!

@mbdeme commented on March 18th 2021

can we use the plugin LoginOIDC to link CAS and motomo version 4?

Yes, you can, it's working perfectly!
Thank you very much I will watch this.

@tsteur commented on March 18th 2021 Member

@mbdeme @dlecan from what I understand this works and we could close this issue?

Powered by GitHub Issue Mirror