@DevDavido opened this Issue on December 24th 2020

Hello there 👋

My Matomo 4.1.0 (running on PHP 7.2.18) installation says "PerformanceAudit requires Piwik <4.0.0-b1." which prevents me from updating the plugin even though the plugin is available and released for Matomo 4.x as also seen in its plugin.json and marketplace page.

Is there some hick up on Matomos side or on the plugins side?

@Findus23 commented on December 24th 2020 Member

Hi,

What happens when you go to the marketplace and update (or uninstall and install the latest version) the plugin?

@DevDavido commented on December 26th 2020

Under Settings ⮁ Platform ⮁ Marketplace the PerformanceAudit plugin doesn't show up in Matomo 4.1. And the marketplace page already shows the latest, updated version. Is that what you were referring to?

Is there any special treatment of plugins by Matomo if they are in beta?

@tsteur commented on December 27th 2020 Member

Hi @DevDavido you would likely need to enable receiving beta versions in Admin => General Settings => Release Channels. Then you would be able to update to it maybe. It be best to create an issue in the plugin's repo to release a stable version in https://github.com/DevDavido/performance-audit-plugin Let me know if this doesn't work and I'll be happy to reopen. The plugin developer would need to release a non-beta version though.

@DevDavido commented on December 28th 2020

Thanks @tsteur, the release of a non-beta version of the plugin made the update possible.

This Issue was closed on December 27th 2020
Powered by GitHub Issue Mirror