@tsteur opened this Pull Request on August 18th 2020 Member

This makes sure when updating eg from Matomo 3.x to Matomo 4.x that these plugins won't be detected as bogus and ensures they will be updated.

The version number needs to be set to fix otherwise the plugins will later be assumed to have the same version as core and potentially no update would be found on the marketplace. It's fine to set a fixed number we won't need to change it again in 3.X since it would be only needed if they defined their own plugin updates.

I'll later look into creating separate updates for 4.X to handle it for instances that don't upgrade from most recent 3.X version. Will work on this in eg https://github.com/matomo-org/matomo/compare/plugincheck?expand=1

This Pull Request was closed on August 18th 2020
Powered by GitHub Issue Mirror