@tsteur opened this Pull Request on April 15th 2020 Member

fix https://github.com/matomo-org/matomo/issues/15771

To reproduce issue you can change $piwik_minimumPHPVersion = '7.2.0'; to eg $piwik_minimumPHPVersion = '7.5.0'; and temporarily remove your config/config.ini.php. You will then see it shows a fatal error because the auto loader has not been loaded yet.

With this patch it shows correct error message
image

Not needed for 3.X since most users would have PHP 5.5+ anyway.

Also removed the sentence mentioning PHP4 and PHP 5.3 linking to https://matomo.org/faq/how-to-install/faq_77/ as it's outdated and the solution in https://matomo.org/faq/how-to-install/faq_77/ likely doesn't even work that often and is quite complicated so not too helpful.

This Pull Request was closed on April 15th 2020
Powered by GitHub Issue Mirror