@sgiehl opened this Issue on February 24th 2020 Member

We are currently running tests against PHP 7.2 and 7.3 only. Actually it would be good to run tests against minimum and latest PHP stable release (7.2 and 7.4 at that point).

This won't be directly possible with our current travis setup as PHP 7.4 can't be used with trusty distribution (GD extension doesn't work there)

What actually needs to be done:

  • [x] Make travis scripts compatible with newer travis distributions (xenial / bionic) (see https://github.com/matomo-org/travis-scripts/pull/56)
  • [x] Update PHPUnit, as currently used version is not compatible with 7.4 (see #15581)
  • [x] Update core and plugin .yml files to use a newer distribution and run tests on 7.4
This Issue was closed on April 21st 2020
Powered by GitHub Issue Mirror