@sgiehl opened this Pull Request on February 6th 2020 Member

It's been about 9 months since the Omnifixture has been regenerated. As there have been a lot changes to various fixtures, there are a lot changes in the exptected UI files. Especially in the tracked visitors & numbers

@sgiehl commented on February 6th 2020 Member

Most tests are working again, but there are a few changes left that don't seem correct.

@tsteur @diosmosis Do you know if that change is correct:
https://builds-artifacts.matomo.org/matomo-org/matomo/omnifixture/38167/UIIntegrationTest_ecommerce_log_segmented.png

The additional action says something about that it shouldn't be tracked in that visit. Not sure if that changed in the last months or if something is broken 🤔

@tsteur commented on February 6th 2020 Member

Looking at the FewVisitsWithSetVisitorId it's hard to tell. There is some different visitorId, IP, and User Agent set so would have expected this would be a new visit as also the configId should not match.

@sgiehl commented on February 19th 2020 Member

Had another look. Seems that change is related to #14360. Will check and improve the test, so it does what it is intended to.

@sgiehl commented on March 23rd 2020 Member

Omnifixture is up to date with latest 4.x-dev. Some tests are still failing.

  • OneClickUpdate -> automatic login after update does not work for any reason (also on 4.x-dev)
  • UIIntegrationTest -> metric tooltip fails randomly - didn't find a good way to fix that properly 🤷‍♂

and two tests using the segment editor are failing because of #15719. Those should work again afterwards

This Pull Request was closed on March 24th 2020
Powered by GitHub Issue Mirror