@creativecoder opened this Issue on January 26th 2020

Currently davaxi/sparkline is set to the version dev-multiple-series in composer.json

https://github.com/matomo-org/matomo/blob/5322d058d5afcd2c40e76a13762038e05f0795f3/composer.json#L51)

This results in the following error when running composer require piwik/piwik

Problem 1
    - piwik/piwik 3.13.1 requires davaxi/sparkline dev-multiple-series -> no matching package found.

I believe davaxi/sparkline should instead be set to ~1.2, to install the latest release that includes the changes merged to support displaying multiple series.

@tsteur commented on January 27th 2020 Member

@Findus23 @sgiehl do you maybe know more?

@Findus23 commented on January 27th 2020 Member

@diosmosis should know best about it but I have no idea why this fails. While we should now be using the latest upstream (#15465), the branch still exists and should therefore work in composer (https://github.com/matomo-org/Sparkline/tree/multiple-series)

@diosmosis commented on January 27th 2020 Member

Maybe caused by a composer setting? I'm not sure why this would fail.

@tsteur commented on January 27th 2020 Member

I can reproduce the issue. Not sure why it doesn't work though or how it needs to be configured etc. It looks like we used to use 1.1 so we could change it to 1.2 or so?

@sgiehl commented on January 27th 2020 Member

I've created PRs to update that, but actually the latest release has
another bug, that produces warnings on PHP 5 and an error on PHP 7. Created
a PR to fix it in the lib. Hope it gets merged soon and a new version is
released, so we can update it...

@limitstudios commented on January 30th 2020 Contributor

@sgiehl looks like a new release maybe coming next week https://github.com/davaxi/Sparkline/pull/15#issuecomment-580148795

This Issue was closed on February 6th 2020
Powered by GitHub Issue Mirror