@jimkang opened this Issue on November 27th 2019

Hello. I have a few email reports that I set to "Daily" in the ScheduledReports module. Without fail, they get sent every other day. Is there a workaround for this?

@Findus23 commented on November 27th 2019 Member

Do you have set up a cronjob for Matomo?

@jimkang commented on November 27th 2019

I had not, other than the log ingestion ones! Just saw this and added a cron job for archiving. I'll see if it works.

I'm curious, though, how is it able to send email every other day anyway without that cron job?
Oh, it looks like this is how it is able to work when the job is not set up.

Note that if you do not setup this script as we recommend, Matomo will still work and send your scheduled reports. This works as follows: a visitor viewing one of the websites tracked in Matomo will actually trigger the processing of data and sending the email reports.

Thanks for the help! I thought I looked for this in the docs before, but I somehow did not find those posts.

@tsteur commented on November 27th 2019 Member

@jimkang I'll close the issue for now. Let us know if it doesn't work for you with the cronjob and we're happy to reopen the issue. Cheers

@jimkang commented on November 28th 2019

Still does not seem to work. No emails today, for example.

@jimkang commented on December 3rd 2019

Hey, so it did work two days in a row after I updated the settings again (made a minor change to the content included in the report) and hit save. Thanks!

@tsteur commented on December 3rd 2019 Member

Great to hear @jimkang . Thanks for letting us know.

This Issue was closed on November 27th 2019
Powered by GitHub Issue Mirror