@creativecoder opened this Issue on September 9th 2019

I maintain a composer managed install of Matomo. For several releases now I've been unable to update Matomo because it's composer.json file requires a package that does not exist in packagist: matomo-org/jshrink.

When running composer require piwik/piwik:3.11.0, I get this output

Problem 1
    - Installation request for piwik/piwik 3.11.0 -> satisfiable by piwik/piwik[3.11.0].
    - piwik/piwik 3.11.0 requires matomo-org/jshrink 1.3.1 -> no matching package found.

Potential causes:
 - A typo in the package name
 - The package is not available in a stable-enough version according to your minimum-stability setting
   see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.
 - It's a private package and you forgot to add a custom repository to find it

Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.
@Findus23 commented on September 9th 2019 Member


The package is defined in the package.json:

This hack is required as the original package doesn't support 5.5 anymore, but Matomo needs the support.

As a workaround until Matomo 4 it should work if you add the repositories entry to your composer.json.

@creativecoder commented on September 9th 2019

Thanks! -- I should have seen that in the composer configuration.

I was able to work around the error by copying the same repository config into my project.

@bluikko commented on July 1st 2021

This issue seems to still be present in Matomo 4.x? https://github.com/matomo-org/matomo/issues/14874#issuecomment-529585366 says it should be fixed?

@sgiehl commented on July 1st 2021 Member

@bluikko we meanwhile directly require tedvim/jshrink again, so any requirement of matomo-org/jshrink should be removed.
If you have any similar issues, please create a new issue with a detailed description about the error and how to reproduce

@bluikko commented on July 1st 2021

we meanwhile directly require tedvim/jshrink again

I see - yes, it was about "tedivm" and not "matomo-org". The details are not clear to me right now but seems vendor/tedivm/jshrink was needed to be deleted as part of the install. It is an ExtraTools install so uses composer. Might create a new issue if I get the details, it is clearly not related to this issue.

@sgiehl commented on July 1st 2021 Member

If it is ExtraTools related, please create an issue in the plugin repo https://github.com/digitalist-se/extratools

This Issue was closed on September 9th 2019
Powered by GitHub Issue Mirror