@creativecoder opened this Issue on September 9th 2019

I maintain a composer managed install of Matomo. For several releases now I've been unable to update Matomo because it's composer.json file requires a package that does not exist in packagist: matomo-org/jshrink.

When running composer require piwik/piwik:3.11.0, I get this output

Problem 1
    - Installation request for piwik/piwik 3.11.0 -> satisfiable by piwik/piwik[3.11.0].
    - piwik/piwik 3.11.0 requires matomo-org/jshrink 1.3.1 -> no matching package found.

Potential causes:
 - A typo in the package name
 - The package is not available in a stable-enough version according to your minimum-stability setting
   see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.
 - It's a private package and you forgot to add a custom repository to find it

Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.
@Findus23 commented on September 9th 2019 Member

Hi,

The package is defined in the package.json:
https://github.com/matomo-org/matomo/blob/9855f8c1aaa2e7af6725423ba047fdf54a821106/composer.json#L89-L116

This hack is required as the original package doesn't support 5.5 anymore, but Matomo needs the support.

As a workaround until Matomo 4 it should work if you add the repositories entry to your composer.json.

@creativecoder commented on September 9th 2019

Thanks! -- I should have seen that in the composer configuration.

I was able to work around the error by copying the same repository config into my project.

This Issue was closed on September 9th 2019
Powered by GitHub Issue Mirror