@danielmorlock opened this Issue on June 21st 2019

https://github.com/matomo-org/matomo/blob/2a4eebfd87bde157228037534e1fe93a2ed56e9b/plugins/ExamplePlugin/Updates/0.0.2.php#L10

The namespace seems to be invalid. We are running into the following exception when updating to Matomo 3.9.1:

  [Exception]                                                                                                             
  The class \Piwik\Plugins\ExamplePlugin\Updates_0_0_2 was not found in /var/www/plugins/ExamplePlugin/Updates/0.0.2.php  

core:update run properly when changing the namespace to Piwik\Plugins\ExamplePlugin.

@sgiehl commented on June 23rd 2019 Member

Thanks for the report. You are right, the namespace should not include Updates. Will create a PR to fix that

This Issue was closed on June 24th 2019
Powered by GitHub Issue Mirror