@bigretromike opened this Issue on May 7th 2019

UserAgents:
Kodi/16.1 (Linux; Android 6.0; SHIELD Android TV Build/MRA58K) Android/6.0.0 Sys_CPU/armv8l App_Bitness/32 Version/16.1
Kodi/17.0-ALPHA1 (X11; Linux armv7l) OpenELEC/8.0 HW_RaspberryPi/1.0 App_Bitness/32 Version/17.0-ALPHA1
Kodi/14.1 (Windows NT 6.3; WOW64) App_Bitness/32 Version/14.1

Those are detected correct on module=DevicesDetection&action=detection, all of them are missing browsers families, yet all of them are 'unknown' browser in every raport.
Is that the issue that Kodi browser is not liked with any other family ?

Do adding family for browser will fix that ?

@Findus23 commented on May 7th 2019 Member

Hi,

As you can e.g. see here DeviceDetector (the library Matomo uses and maintains for user agent detection) detects all these user agents as mediaplayer instead of browsers.

There is a quite old issue for Matomo to also support other device types from DeviceDetector: #5413

@Findus23 commented on May 7th 2019 Member

Just noticed that there was this exact discussion two years ago in #5615 :)

@bigretromike commented on May 7th 2019

I dont know how #5615 is exact, but ok.

@Findus23 commented on May 7th 2019 Member
@bigretromike commented on May 7th 2019

Yeah, I dig thru that.
So until https://github.com/matomo-org/matomo/issues/5413 this is possible only by tweaking browsers.yml and Browser.php, not the best solution.

Ok, thanks - looks like module=DevicesDetection&action=detection give wrong results because it say its a Browser where for Piwik/Matomo its not.

@Findus23 commented on May 7th 2019 Member

I am currently in the process of creating a new website that will show the exact DeviceDetector results for a user agent. You can find the current status here: https://devicedetector.lw1.at/

@bigretromike commented on May 7th 2019

Yes, your page does detect it as mediaplayer which is correct, nonetheless the issue is still with the core ;-)
While I have you here, do you know how I could process all data saved in Matomo with newly created browsers so it recognized those old 'unknown' rows ?

This Issue was closed on May 7th 2019
Powered by GitHub Issue Mirror