@andreaproietti opened this Issue on November 20th 2018

Hi, an error occurs opening dashboard. Widget are not loaded, they are empty or there is an infinite loading.

index.php?module=Proxy&action=getCoreJs&cb=eb89e80821ddc8902b51ab5d8d7359fd:3064 Uncaught TypeError: Cannot read property 'length' of undefined
at exports.JqplotBarGraphDataTable._setJqplotParameters (index.php?module=Proxy&action=getCoreJs&cb=eb89e80821ddc8902b51ab5d8d7359fd:3064)
at exports.JqplotBarGraphDataTable.init (index.php?module=Proxy&action=getCoreJs&cb=eb89e80821ddc8902b51ab5d8d7359fd:2996)
at exports.JqplotBarGraphDataTable.DataTable (index.php?module=Proxy&action=getCoreJs&cb=eb89e80821ddc8902b51ab5d8d7359fd:1188)
at exports.JqplotBarGraphDataTable.exports.JqplotGraphDataTable (index.php?module=Proxy&action=getCoreJs&cb=eb89e80821ddc8902b51ab5d8d7359fd:2994)
at new exports.JqplotBarGraphDataTable (index.php?module=Proxy&action=getCoreJs&cb=eb89e80821ddc8902b51ab5d8d7359fd:3064)
at HTMLDivElement. (index.php?module=Proxy&action=getCoreJs&cb=eb89e80821ddc8902b51ab5d8d7359fd:1189)
at Function.each (index.php?module=Proxy&action=getCoreJs&cb=eb89e80821ddc8902b51ab5d8d7359fd:4)
at n.fn.init.each (index.php?module=Proxy&action=getCoreJs&cb=eb89e80821ddc8902b51ab5d8d7359fd:4)
at Function.DataTable.initNewDataTables (index.php?module=Proxy&action=getCoreJs&cb=eb89e80821ddc8902b51ab5d8d7359fd:1189)
at HTMLDocument.eval (eval at globalEval (index.php?module=Proxy&action=getCoreJs&cb=eb89e80821ddc8902b51ab5d8d7359fd:4), :2:39)

@tsteur commented on November 20th 2018 Member

just double checking: are you using the latest Matomo version? Is it a new install or did it used to work?

@andreaproietti commented on November 20th 2018

Hi, we are using the latest version. It never worked, we are using it via API, but it would be much easier to use the dashboard.

@tsteur commented on November 21st 2018 Member

Is that in all browsers? Do you use any plugins that are not from Matomo/Piwik or InnoCraft?

@andreaproietti commented on November 21st 2018

Yes it is in all browsers, both desktop and mobile. We are using only official plugins ( Core (54) | Official (5) | Third-parties (0).

Attached you will find three samples of dashboard at opening...

20181121_070628
20181121_070659
20181121_070719

@tsteur commented on November 22nd 2018 Member

Are there maybe any extensions enabled like modpagespeed or such things? it's quite hard to tell what the problem possibly could be. feel free to send us details to your matomo instance to hello at matomo.org and we can possibly have a quick look if we find something

@andreaproietti commented on November 23rd 2018

I wrote you an email with instance details. Please help us! :D

Powered by GitHub Issue Mirror