@larsen0815 opened this Issue on July 2nd 2018

Using Matomo 3.5.1 (on Debian Stretch), I have downloaded the plugin from https://plugins.matomo.org/SiteMigration and unzipped it into the plugins directory.

When I run ./console migration:site --help from the main directory, I get this error message:

[InvalidArgumentException]
  There are no commands defined in the "migration" namespace.

Same happens when I try to migrate a siteID.
As version 1.0.8 has last been updated in 2015, I suspect it's not compatible anymore.

@sgiehl commented on July 2nd 2018 Member

Correct. The plugin might not be compatible with Matomo 3+ as it isn't maintained anymore.

@ma2thieu commented on September 18th 2018

After unzipping the plugin files you need to activate the plugin in Matomo admin panel or else you get this error message.
I just migrated one site between two Matomo 3.5.1 instances with SiteMigration 1.0.8 and it worked well.

Powered by GitHub Issue Mirror