@eldk opened this Issue on June 19th 2018

Hello,

Matomo : beta 3.5.1

When year is selected as default date to display report : nothing is displayed (day, month ... are OK).

This is both for login and anonymous users.

One example url :
https://domain.tld/index.php?module=CoreHome&action=index&idSite=5&period=year&date=today#?idSite=5&period=year&date=today&category=Dashboard_Dashboard&subcategory=1

screenshot-2018-6-19- web analytics reports - matomo

Thanks,

Eric

PS : as I have change nothing on Matomo config for a long time. I don't think it's a config concern. Matomo is only updated when a new version is available.

@sgiehl commented on June 20th 2018 Member

Are there results when you switch to year in the period selector?

@eldk commented on June 22nd 2018

Hello,

Are there results when you switch to year in the period selector?

No.

I try to investigate now. Error log ...

Thanks,

Eric

@eldk commented on June 22nd 2018

Hello,

Restart whole server : year data are displayed as expected.

So no bug, but something that was maybe crashed or wrong in mysql cached datas.

Close it.

Thanks,

Eric

@eldk commented on July 14th 2018

Hello,

Checking stats today, I got the same thing again. Other period than year have no problem.

It's the same for anonymous user - stats are public - or login user.

I have change period to current month and stats are displayed.

https://neptune.opalesurfcasting.net/

I'll try to investigate in next days.

Thanks,

Eric

PS : I don't restart the server

@eldk commented on July 20th 2018

Hello,

I change nothing, nor restart server, change config ... year datas are back.

I let it run and see if it disappear again.

Eric

PS : as I use it with few datas, and only for some volunteers, some days are without any data. I will check it once a day to try to reproduce.

@tsteur commented on July 20th 2018 Member

Closing for now. Likely the data was just not archived. But there shouldn't be a problem with year as default date. Feel free to reopen if data is not there with year as default but when you select it through the date chooser.

If not done yet, I recommend to set up a CLI archiver: https://matomo.org/docs/setup-auto-archiving/

@eldk commented on July 22nd 2018

Hello,

It's occured again : no stats for year. Datas are not there through date chooser and as default.

Cron task is in place since Piwik/Matomo used :

(/usr/bin/php5 /way/to/piwik/console core:archive --url=https://neptune.opalesurfcasting.net/ > /way/to/piwik-archive/piwik-archive.log)
INFO [2018-07-22 15:30:02] 28055  ---------------------------
INFO [2018-07-22 15:30:02] 28055  INIT
INFO [2018-07-22 15:30:02] 28055  Running Matomo 3.5.1 as Super User
INFO [2018-07-22 15:30:02] 28055  ---------------------------
INFO [2018-07-22 15:30:02] 28055  NOTES
INFO [2018-07-22 15:30:02] 28055  - Reports for today will be processed at most every 150 seconds. You can change this value in Matomo UI > Settings > General Settings.
INFO [2018-07-22 15:30:02] 28055  - Reports for the current week/month/year will be requested at most every 3600 seconds.
INFO [2018-07-22 15:30:02] 28055  - Archiving was last executed without error 5 min 0s ago
INFO [2018-07-22 15:30:02] 28055  ---------------------------
INFO [2018-07-22 15:30:02] 28055  START
INFO [2018-07-22 15:30:02] 28055  Starting Matomo reports archiving...
INFO [2018-07-22 15:30:02] 28055  - no new tracking data for website id 4 since 2018-07-22 15:25:02 UTC (since the last successful archiving)
INFO [2018-07-22 15:30:02] 28055  Skipped website id 4 as archiving is not needed
INFO [2018-07-22 15:30:02] 28055  - no new tracking data for website id 5 since 2018-07-22 15:25:02 UTC (since the last successful archiving)
INFO [2018-07-22 15:30:02] 28055  Skipped website id 5 as archiving is not needed
INFO [2018-07-22 15:30:02] 28055  - no new tracking data for website id 6 since 2018-07-22 15:25:02 UTC (since the last successful archiving)
INFO [2018-07-22 15:30:02] 28055  Skipped website id 6 as archiving is not needed
INFO [2018-07-22 15:30:02] 28055  Done archiving!
INFO [2018-07-22 15:30:02] 28055  ---------------------------
INFO [2018-07-22 15:30:02] 28055  SUMMARY
INFO [2018-07-22 15:30:02] 28055  Total visits for today across archived websites: 0
INFO [2018-07-22 15:30:02] 28055  Archived today's reports for 0 websites
INFO [2018-07-22 15:30:02] 28055  Archived week/month/year for 0 websites
INFO [2018-07-22 15:30:02] 28055  Skipped 3 websites
INFO [2018-07-22 15:30:02] 28055  - 3 skipped because no new visit since the last script execution
INFO [2018-07-22 15:30:02] 28055  - 0 skipped because existing daily reports are less than 150 seconds old
INFO [2018-07-22 15:30:02] 28055  - 0 skipped because existing week/month/year periods reports are less than 3600 seconds old
INFO [2018-07-22 15:30:02] 28055  Total API requests: 0
INFO [2018-07-22 15:30:02] 28055  done: 0/3 0%, 0 vtoday, 0 wtoday, 0 wperiods, 0 req, 292 ms, no error
INFO [2018-07-22 15:30:02] 28055  Time elapsed: 0.292s
INFO [2018-07-22 15:30:02] 28055  ---------------------------
INFO [2018-07-22 15:30:02] 28055  SCHEDULED TASKS
INFO [2018-07-22 15:30:02] 28055  Starting Scheduled tasks... 
INFO [2018-07-22 15:30:02] 28055  done
INFO [2018-07-22 15:30:02] 28055  ---------------------------

I have sent datas 'site id: 5) at 15:36:15 UTC, waiting cron task ....

@eldk commented on July 22nd 2018

And archiving task seems to be right and year range data processed:

INFO [2018-07-22 15:40:01] 28489  INIT
INFO [2018-07-22 15:40:01] 28489  Running Matomo 3.5.1 as Super User
INFO [2018-07-22 15:40:01] 28489  ---------------------------
INFO [2018-07-22 15:40:01] 28489  NOTES
INFO [2018-07-22 15:40:01] 28489  - Reports for today will be processed at most every 150 seconds. You can change this value in Matomo UI > Settings > General Settings.
INFO [2018-07-22 15:40:01] 28489  - Reports for the current week/month/year will be requested at most every 3600 seconds.
INFO [2018-07-22 15:40:01] 28489  - Archiving was last executed without error 4 min 59s ago
INFO [2018-07-22 15:40:01] 28489  ---------------------------
INFO [2018-07-22 15:40:01] 28489  START
INFO [2018-07-22 15:40:01] 28489  Starting Matomo reports archiving...
INFO [2018-07-22 15:40:01] 28489  - no new tracking data for website id 4 since 2018-07-22 15:35:02 UTC (since the last successful archiving)
INFO [2018-07-22 15:40:01] 28489  Skipped website id 4 as archiving is not needed
INFO [2018-07-22 15:40:01] 28489  - tracking data found for website id 5 since 2018-07-22 15:35:02 UTC (since the last successful archiving)
INFO [2018-07-22 15:40:01] 28489  Will pre-process for website id = 5, period = day, date = last2
INFO [2018-07-22 15:40:01] 28489  - pre-processing all visits
INFO [2018-07-22 15:40:03] 28489  Archived website id = 5, period = day, 0 segments, 1 visits in last 2 days, 1 visits today, Time elapsed: 1.574s
INFO [2018-07-22 15:40:03] 28489  Will pre-process for website id = 5, period = week, date = last3
INFO [2018-07-22 15:40:03] 28489  - pre-processing all visits
INFO [2018-07-22 15:40:05] 28489  Archived website id = 5, period = week, 0 segments, 18 visits in last 3 weeks, 3 visits this week, Time elapsed: 2.162s
INFO [2018-07-22 15:40:05] 28489  Will pre-process for website id = 5, period = month, date = last3
INFO [2018-07-22 15:40:05] 28489  - pre-processing all visits
INFO [2018-07-22 15:40:07] 28489  Archived website id = 5, period = month, 0 segments, 57 visits in last 3 months, 18 visits this month, Time elapsed: 2.484s
INFO [2018-07-22 15:40:07] 28489  Will pre-process for website id = 5, period = year, date = last3
INFO [2018-07-22 15:40:07] 28489  - pre-processing all visits
INFO [2018-07-22 15:40:10] 28489  Archived website id = 5, period = year, 0 segments, 1972 visits in last 3 years, 578 visits this year, Time elapsed: 2.554s
INFO [2018-07-22 15:40:10] 28489  Will pre-process for website id = 5, period = range, date = last30
INFO [2018-07-22 15:40:10] 28489  - pre-processing all visits
INFO [2018-07-22 15:40:11] 28489  Archived website id = 5, period = range, 0 segments, 22 visits in last 30 ranges, 22 visits this range, Time elapsed: 1.313s
INFO [2018-07-22 15:40:11] 28489  Archived website id = 5, 5 API requests, Time elapsed: 10.129s [2/3 done]
INFO [2018-07-22 15:40:11] 28489  - no new tracking data for website id 6 since 2018-07-22 15:35:02 UTC (since the last successful archiving)
INFO [2018-07-22 15:40:11] 28489  Skipped website id 6 as archiving is not needed
INFO [2018-07-22 15:40:11] 28489  Done archiving!
INFO [2018-07-22 15:40:11] 28489  ---------------------------
INFO [2018-07-22 15:40:11] 28489  SUMMARY
INFO [2018-07-22 15:40:11] 28489  Total visits for today across archived websites: 1
INFO [2018-07-22 15:40:11] 28489  Archived today's reports for 1 websites
INFO [2018-07-22 15:40:11] 28489  Archived week/month/year for 1 websites
INFO [2018-07-22 15:40:11] 28489  Skipped 2 websites
INFO [2018-07-22 15:40:11] 28489  - 2 skipped because no new visit since the last script execution
INFO [2018-07-22 15:40:11] 28489  - 0 skipped because existing daily reports are less than 150 seconds old
INFO [2018-07-22 15:40:11] 28489  - 0 skipped because existing week/month/year periods reports are less than 3600 seconds old
INFO [2018-07-22 15:40:11] 28489  Total API requests: 5
INFO [2018-07-22 15:40:11] 28489  done: 1/3 33%, 1 vtoday, 1 wtoday, 1 wperiods, 5 req, 10407 ms, no error
INFO [2018-07-22 15:40:11] 28489  Time elapsed: 10.407s
INFO [2018-07-22 15:40:11] 28489  ---------------------------
INFO [2018-07-22 15:40:11] 28489  SCHEDULED TASKS
INFO [2018-07-22 15:40:11] 28489  Starting Scheduled tasks... 
INFO [2018-07-22 15:40:11] 28489  done
INFO [2018-07-22 15:40:11] 28489  ---------------------------

year range datas are also displayed in dashboard now.

@eldk commented on July 22nd 2018

Site id: 5 (I only get datas from some volunteers (mobile app)
Last visit : Sunday, July 22, 2018 - 15:36:03 UTC
Last visit -1 : Thursday, July 19, 2018 - 17:12:56 UTC

So last time -1 year datas have been archived is between 17:15 and 18:15 on Thursday.

Is there a link with it ?

As I have a second tracked site with some more visits (site id 6), I will check on next time if its year datas are displayed while Site id 5 are not.

Thanks,

Eric

PS : "Archive reports when viewed from the browser" was disabled, I let it as this for the moment.
PS2 : I have enable continuous logging

@tsteur commented on July 22nd 2018 Member

Maybe it is not archiving year period when there are no new visits... but then the previously generated yearly archive should be still valid and used in the reports.

@tsteur commented on July 22nd 2018 Member

Does current month work?

@eldk commented on July 23rd 2018

Hello,
All is always working, except year range that sometimes give "no data".
I'm logging ...

Maybe it is not archiving year period when there are no new visits...
I think there is something like that

but then the previously generated yearly archive should be still valid and used in the reports.
I agree.

  • it's never happened before update to Matomo 3.5.1
@eldk commented on August 12th 2018

Hello,

I have upgraded to 3.6.0-b5 : no change.

I haven't had time yet to dig in it.

Month :
screenshot_2018-08-12 visits over time - month matomo
Year :
screenshot_2018-08-12 visits over time - year - matomo

There's no threat as it seems to happened on domain with very low pageviews and only for year view - here one domain with one landing page used a few days in year.

Thanks,

Eric

@eldk commented on October 9th 2018

Hello,

I have upgraded to 3.6.1-n, and Matomo is now up to last beta.

Never happened again with 3.6.1.

Thanks,

Eric

@tsteur commented on October 9th 2018 Member

:+1:

This Issue was closed on July 20th 2018
Powered by GitHub Issue Mirror