@Sobhika2 opened this Issue on February 16th 2018


I am getting an error while trying to access the MarketPlace in Piwik version 3.2.0. The error also appears while accessing the Administration tab. Attached is the error screens for the same.

The log displays below error messages:

[Fri Feb 16 12:41:52 2018] [error] [client] Error in Piwik: , referer: http://piwik-test.swissre.com/piwik/index.php?module=CoreAdminHome&action=home&idSite=1&period=day&date=yesterday&activated=

Can anybody help?


@cawale commented on March 2nd 2018

I am seeing the same thing.

@tsteur commented on March 3rd 2018 Owner

Did it just suddenly stop working? Where there maybe any changes like a Piwik/Matomo update or server update or something?

@Findus23 commented on March 3rd 2018 Member
@cawale commented on March 5th 2018

Tried the solution that you suggested but no luck.

This is a new install v 3.3.0. I can get out to the internet from the server. I have used apt-get lots to get Matomo setup.

@Sobhika2 commented on March 5th 2018

I was able to fix this issue by changing the domain value to $domain = ‘http://plugins.matomo.org/’; in the config file under the below path : /opt/pwk/piwik/plugins/Marketplace/config # vi config.php.

I believe the redirection from piwik to matomo was not defined which was creating the issue.

@tsteur commented on March 5th 2018 Owner

It should have still worked with plugins.piwik.org (just tested it here) but glad it works now.

This Issue was closed on March 5th 2018
Powered by GitHub Issue Mirror