@Croydon opened this Issue on July 29th 2016

If Piwik detects incompatible plugins it displays a warning message.
However, even the message itself is written in plural form only one plugin is randomly(?) named, even there are serveral plugins incompatible as one can see on the manage plugins site.

Just a minor bug, but it should still list all incompatible plugins.

piwikplugins

Piwik 2.16.1, PHP 7

@tsteur commented on July 30th 2016 Member

It should list all incompatible plugins. Can you post a screen of the "manage plugins" page where it lists more invalid plugins? Or which plugins is it reporting as invalid?

Maybe we are missing a call to isManifestFileFound here: https://github.com/piwik/piwik/blob/2.16.1/core/Plugin/Manager.php#L1049

@Croydon commented on July 30th 2016

@tsteur Incompatible are: ExampleFeedburner, SecurityInfo (which is in the message) and VisitorGenerator.

@tsteur commented on July 30th 2016 Member

For ExampleFeedburner it could be indeed the missing manifest file while there should be one provided for VisitorGenerator unless it is a very old version. Thanks for getting back so quickly

@Croydon commented on January 11th 2020

I personally no longer use Matomo and could not reproduce this anyway.

The issue was also not a major one

And I would assume that missing manifest files in plugins might be a legacy thing, which only happens with (in the meantime) very, very old plugins.

Closing

This Issue was closed on January 11th 2020
Powered by GitHub Issue Mirror