@tuxmaster opened this Issue on May 9th 2018

Hello the last matomo comes with archive_tar 1.4.2, but this version fails with php 7.2
For example the download of the geoip2 data bases fails with:

PHP Fatal error: Cannot use result of built-in function in write context in /var/www/piwik/html/vendor/pear/archive_tar/Archive/Tar.php on line 662

This bug is also noted on the pear site

@fdellwing commented on May 9th 2018 Contributor

Please note that PHP7.2 is still not officially supported. This should be fixed nonetheless.

@Findus23 commented on May 9th 2018 Member

Oddly I am using PHP 7.2 and didn't have the issue.

@DvdGiessen commented on May 9th 2018

@fdellwing What is the correct supported range of PHP version for the latest version (3.5.0 as of writing) of Matomo? As per the documentation and the README distributed with the latest version the required PHP version is "5.5.9 or greater".

Might it perhaps be a good idea to document up till which version of dependencies Matomo was tested to work correctly for a given release? That would also ensure that the required versions are clear in the future.

If hypothetically the PHP team would release a version 8 which breaks Matomo in every way imaginable, right now we'd have to update documentation to explicitly state it is not supported. Even then, we cannot update the README files included in previous releases. If we denote the last version that Matomo was tested against, users at least have a reference as to what is supposed to work and what is something to try at their own risk.

@futureweb commented on May 9th 2018 Contributor

alright - until Matomo is updated to archive_tar 1.4.3 --> quick and dirty fix ...

https://github.com/pear/Archive_Tar/commit/772f7d0ffaf225d575ac1feca44eefcd4a9b144e

@fdellwing commented on May 9th 2018 Contributor

Might it perhaps be a good idea to document up till which version of dependencies Matomo was tested to work correctly for a given release? That would also ensure that the required versions are clear in the future.

As far as I'm aware of travis runs with PHP5.6 but PHP7.0 is recommended. That is not optimal, but it means that >PHP7.0 is tested even less. So specifing this should be a good idea. @mattab

This Issue was closed on May 9th 2018
Powered by GitHub Issue Mirror